Netzwerk Profi gesucht :-) WireGuard VPN, OpenWRT, Fritz!Box, Pekaway

Moin, gibt es hier vielleicht einen Netzwerk Profi der mir beim Routing vielleicht helfen kann.

Das VPN zwischen Home Fritz!Box und Auto OpenWRT steht, ich komme aber von der Fritz!Box nicht auf den Vanpi Raspi.

Also erstes Ziel ist vom Home Lan aufs Vanpi, das zweite Ziel ist dann vom iPhone (ist auch mit dem Home Lan per Wireguard verbunden.

Wahrscheinlich ist das für jemanden der sich auskennt echt lächerlich, ich komme dabei leider an meine Grenzen.

Also vielen Dank schonmal, und frohe Weihnachten.

Die Frage, ob man den Pi als AP schalten muss, oder in ein Netzwerk einbinden kann hatte mich auch schon umgetrieben. Lies mal diesen Post VanPi per LAN verbinden

Ne das ist nicht das Problem, ich habe ihn ja als Client im Netz und das funktioniert, wenn ich auf dem OpenWRT Router bin komme ich ganz normal an den Pi dran, nur aus dem VPN nicht.

Allright, da kann ich leider doch nicht helfen :smiley: Frohes Fest

Hey Hey, schau mal hier ist einen Anleitung Community Content | Pekaway - VANPI the AIO CamperUnit … weiter unten " Zugriff auf das System über VPN by Jan" Da hab ich unterandem auch beschrieben, dass die Sim-Karte die im Router im Auto ist eine Öffentliche IP-Adresse haben muss. Das kann man im Falle von O2 am Telefon beantragen kostet einmalig 30€. Kann mir vorstellen, dass das dein Problem löst. Ein anderes selbst gestelltes Problem war bei mir, dass ich dem RaspberryPi auf der Fritzbox mittels der Kindersicherung den Internetzugang verweigert hatte. Das gilt auch wenn man via VPN auf den Pi zugreifen will. Noch als Ergänzung gegen Missverständnisse die LTE-Fritzbox ist im Boot/Auto.

grade entdeckt der Link führt ins Leere… vielleicht kann @Karl das mal checken?

hier der passende Abschnitte bei dem Oben genannten Preis hab ich mich geirrt.

Soweit so gut! Der VPN funktioniert! Jedoch nur solange ihr im Wlan seid! Jetzt wird es etwas technischer. Eure FritzBox bzw. eure Sim-Karte besitzt keine öffentliche IP Adresse (eine digitale Adresse, vergleichbar mit eurer Postanschrift). Die könnt ihr euch bei eurem Provider beantragen. Bei O2 beispielsweise könnt ihr anrufen und euch eine „öffentliche IP Adresse“ zuteilen lassen. Das kostet einmalig ca. 50 € und ist für alle Sim-Karten eures Vertrags. An der FritzBox! müsst ihr nun noch einige Änderungen vornehmen. (https://hilfe.o2online.de/o2-homespot-o2-my-data- spot-21/tutorial-oeffentliche-ip-nat-typ-2-beantragen-und-einrichten-im-o2-homespot-2-581919)

Dazu im Fritzbox Menü auf Internet → Zugangsdaten. Dort übernehmt ihr die Daten aus dem Screenshot. (Hier Bild 3)
Im Falle von O2
Internetanbieter: „andere Internetanbieter“

Zugangspunkt: „netpublic“

Moin @BastelMarvin ,

1000 Dank, ich denke genau das ist das Problem also das mit der Privaten IP und bei O2 bin ich auch, also werde ich dort am Dienstag mal Anrufen und das Buchen.
Im Bulli ist ein GL.inet Router mit OpenWRT. Aktuell habe ich das Setup hier liegen und es funktioniert soweit. Hoffe das es nun wirklich nur noch an der Privaten IP liegt.

Vielen Dank und viele Grüße

1 Like

Alles kein Problem.

Mein Setup:

  • FritzBox im Heimathafen
  • Teltonica im Sprinter
  • als VPN nutze ich Wireguard
  • Verbindungsaufbau IMMER von Sprinter zum Heimathafen

Fertig.

So kann ich von Zuhause auf den Sprinter zugreifen.

War mir nicht genug. Deshalb alle mobilen Devices bei uns zusätzlich mit dem Heimathafen (per Wireguard) verbunden. Nun können wir auch in der Ski-Gondel die Standheizung einschalten, den Lüfter aktivieren oder den Kühlschrank abschalten.

… und auch über die ESP32-Cam nach dem Hund schauen! :slight_smile:

P.S.: Private IP von O2 ist völlig irrelevant. Wichtig ist, dass Du immer zum Heimathafen eine IP hast. Die kannst Du dynamisch nutzen (dann einen DNS-Namen zur Auflösung verwenden).

Hey danke für deine Hilfe,

ja genau so will ich es ja machen, also die Fritz ist im Heimathafen und der GL.inet (Openwrt) ist im Bulli.
WireGuard Server ist die Fritz!Box und der GL.inet ist der Client. Genau so wie mein iPhone und was auch immer.
Iphone - Fritzbox klappt Super
GL.inet im per WAN an die Fritz!Box klappt auch, dann kann er auch das WirGuard verbinden und ich kann dann egal in welchem WLAN ich bin auf beide Netzwerke Zugriefen.
Sobald ich aber den WAN/LAN Stecker ziehe und das ganze nur noch über LTE machen will bricht die Wireguard Verbindung ab.
Hab mir heute sogar extra ne Öffentliche IP von O2 geben lassen.

Also ich bin für jeden Tipp dankbar.

@BT6100 vielleicht magst du ja nochmal etwas zu deiner Konfiguration sagen.

Viele Grüße
Sven

Ich würde jetzt erst mal suchen, was die Ursache für den Verbindungsabbruch ist. Baust Du wirklich die Verbindung von deinem Bulli ZUM Heimathafen auf? Die Richtung ist entscheidend.

Poste doch mal deine Konfiguration, aber ENTFERNE DIE KEYS!!!

Anbei ein Foto von dem Router der in den Bulli sein soll, also von der Peer Seite.
Dabei ist es egal ob die erlaubte IP die 0.0.0.0. ist oder die vom Fritz Netz ist. Wenn der Bulli Router per WAN verbunden ist geht es, via 4G nicht

Probiere mal die Konfiguration ohne den Hostnamen myfristz und gebe nur die IP Adresse von deinem Heimathafen ein. Funktioniert es dann?

Und mach die Konfiguration mal manuell, eventuell geht etwas bei deinem Import schief.

Worauf läuft der OpenWrt?

Bei Allowed IPs würde ich nur dein INTERNES HEIMATHAFEN Netz hinterlegen, sonst gehst Du über deinen Heimathafen ins Internet.

Arrrrrggg ich hab es hinbekommen. :smiling_face_with_three_hearts:

Und es lag nicht am Router oder O2 sondern am Fucking Cable von Vodafone, Problem dabei ist, man bekommt keine IPv4 sondern nur noch iPV6, mit dem iPhone geht es komischerweise trotzdem, dahin einen Tunnel aufzubauen, mit dem OpenWRT Router leider nicht. Naja nun hab ich den Tunnel halt in mein Büro gemacht.

Trotzdem danke für die Hilfe
Guten Rutsch

Na siehste!

Was ist denn die Basis von deinem OpenWRT?

Ein GL.inet X300b, aber mit einem sauberen OpenWRT.

1 Like

Cooles Teil - sieht nach einer Option für den mobilen Einsatz aus. Ich habe hier noch einen Teltonica - will langfristig aber 5G und muss daher da auch nochmal ran.

Verstehe ich das jetzt richtig, ihr macht also eine 3 Ecks Verbindung? Auto verbindet sich mit VPN nach Hause und euer Handy dann nach Hause und dann von da weiter zum Auto? Dann passt das wieder, dass man im Auto keine Öffentliche IP brauch, da zu Hause ja eine ist und die Richtung dann wie von @BT6100 beschrieben natürlich relevant.

Das mit IPV6 hatte ich völlig verdrängt, das es dort auch Probleme geben kann. Sorry! @Bock.auf.Raus

Korrekt.

So ballert auch der Camper seine Daten per MQTT in meine HomeAssistant Umgebung :heart_eyes:

@BastelMarvin alles gut, ich hab ja selbst ne Woche dran rumbasteln müssen bis ich mal drauf gekommen bin :sweat_smile:
Naja, nun läuft es ja, ich werde bei Gelegenheit das ganze wenn es eingebaut ist noch vorstellen.

1 Like